Problem with electric bike going slow

Discussion in 'General Bike Discussion' started by roaringfire, Mar 3, 2010.

  1. roaringfire

    roaringfire New Member

    17
    0
    0
    I have just been given a replacement Raw folding electric bike and it doesn't deliver the proper power. I am lucky if at full throttle is takes me along and 6-8 miles an hour whereas they are normally reasonably quick and limited to 20 mph. When I use the pedal assist rather than the throttle it seems to create a bit more power compared to throttle and not including the pedalling but it is still uselessly slow. I am having a warranty battle with the importer so am looking to find if there is a simple fix for this, whether its likely the throttle, or controller or the in wheel brushless motor? It's supposed to be 300W as advertised but when I opened it up it's just 250W.

    Any suggestions?

    Thanksa
     
  2. TxCyclist

    TxCyclist Administrator Staff Member Admin Staff

    2,475
    11
    38
    When you check the battery charge after it's been fully charged is it holding?
     

  3. roaringfire

    roaringfire New Member

    17
    0
    0
    So many thanks for the quick response.

    It appears to be. By that do you mean if I was to reconnect the charger it would still be showing as being fully charged? Certainly the throttle indicator also seems happy with the charge level. The three batteries all see to be properly connected so unless one or two of the batteries are DOA I don't know how this can be the issue? Any idea's.