Wahoo computers and indoor cycling

Discussion in 'Gear & Accessories' started by John_V, Aug 2, 2020.

  1. John_V

    John_V Moderator Staff Member Mod Team Tavern Member

    9,639
    3,610
    113
    I posted an issue on Wahoo's User Group and haven't received any replies so I thought I would try here as well since many of you ride indoors with Zwift and other virtual cycling apps.

    Wahoo has been having some major issues lately with their companion app doing all sorts of weird stuff. Seems like every time they attempt to fix it, they break something else. The latest issue I have is that the rides I've been doing that are marked as Indoor rides don't sync to the companion app. Seems like only rides that are marked Outdoor sync after a ride is completed. Another issues is that when you open the companion app, it automatically defaults to Outdoor and sets my Bolt to Outdoor as well. I have to check the Bolt and change it every time I do a ride.

    I would like to know if anyone else is having this issue before I open a ticket with Wahoo. I already have three open tickets with them now, concerning the companion app, that have not been corrected. I would like to know if others have had this issue so I can relay that to them.
     
  2. kneedrachen

    kneedrachen Moderator Mod Team Tavern Member

    8,414
    1,066
    113
    Yes and the other (known by Wahoo) is after an update (not sure if app or on the Bolt) is that it keeps resetting to "custom" units of measure: miles for distance, kg for weight, feet for climbing, Celsius for temperature.

    Opened a ticket and they said they knew of the issue and to keep everything updated as often as possible.

    I'll set everything to "Imperial" and its a crapshoot if my settings hold upon completion.
     
    John_V and MilesR like this.

  3. kneedrachen

    kneedrachen Moderator Mod Team Tavern Member

    8,414
    1,066
    113
    They ( Wahoo) bought Speedplay and just bought The Sufferfest. Methinks resources are focused elsewhere for the time being.
     
    John_V, rola643 and Dos_Ruedas like this.
  4. rola643

    rola643 Two skinny Js Staff Member Admin Staff Mod Team Tavern Member

    20,465
    8,885
    113
    No help, I've not had any of those issues mentioned by either of you. I don't use the Wahoo Element in Zwift or any indoor rides. No point in it with Zwift and a smart trainer. I have more issues having " to forget a Bluetooth device" for pairing reason and my TCKR is the absolute worst for this!

    The other issue I ave with the app is synching with other apps. It used to auto upload to the sites I use and now I have to go in and force it to start after a ride. I've done the "forget phone" and it's just quicker to force a synch sadly.
     
    John_V likes this.
  5. kneedrachen

    kneedrachen Moderator Mod Team Tavern Member

    8,414
    1,066
    113
    @rola643 , I don't either, but outdoor rides in my world are Imperial...unless they're not.
     
    John_V, MilesR and Dos_Ruedas like this.
  6. John_V

    John_V Moderator Staff Member Mod Team Tavern Member

    9,639
    3,610
    113
    Dropping connections is a major issue with a lot of Wahoo user on the forum. The User Group is flooded with complaints. This apparently started with one of the firmware updates back in March and they haven't fixed it yet. It appears that since the upgrade, the computers are wanting to connect via BTLE over Ant+ and that is where they get dropping issues. The workaround is to have your sensors connected via Ant+. I've always had my sensors connected via Ant+ so I have never experienced that problem.

    You will need a cycling app, like Wahoo Fitness (not the companion app), or any other cycling app that supports sensors, to do this with. Unpair all your sensors from your computer and turn the computer off. Pair all your sensors to your phone app via BTLE. Keeping the phone ON and the sensors connected, turn ON the computer and pair them via the Ant+ channel. This should stop any of the dropouts you are experiencing.

    The syncing with other apps, like Strava, is another issue that is big on the forum. I don't know what they did to the companion app but it appears to be totally broken. What used to work flawlessly is now a mess. I hope they get their act together and get this stuff fixed or they are going to lose a lot of customers.
     
    kneedrachen and rola643 like this.
  7. John_V

    John_V Moderator Staff Member Mod Team Tavern Member

    9,639
    3,610
    113
    Well, I sent in a ticket to Wahoo Support to which they responded to on the first day. I was told that they just released a new version of the companion app (ver 1.33.3) and to download it from the App Store. Did that and now the rides marked "Indoors" are syncing but when the file is exported from the companion app, the mileage is always 0.0 miles. Shows correctly on the Bolt and in the History Page but not in the exported file uploaded to any of the third party sites. So now I have to edit the file and insert the mileage and upload the file manually to my third party sites. Wonderful!
     
  8. kneedrachen

    kneedrachen Moderator Mod Team Tavern Member

    8,414
    1,066
    113
    What about just tracking via the Bolt and having it upload? Bypass the companion app completely?
     
    John_V likes this.
  9. John_V

    John_V Moderator Staff Member Mod Team Tavern Member

    9,639
    3,610
    113
    It will upload by WiFi directly from the Bolt with no problems. But since there’s no GPS tracking in the FIT file, Strava sees it as a zero distance ride. RWGPS does the same.

    What’s strange is all my rides are exported from the companion app into Cyclemeter. In Cyclemeter, the distance and everything else is shown correctly. I can then export the ride from Cyclemeter as a TCX file and upload it to Strava and RWGPS and it uploads correctly. Weird sh1t.
     
  10. kneedrachen

    kneedrachen Moderator Mod Team Tavern Member

    8,414
    1,066
    113
    Very odd, with Zwift I've paired my HR, Speed and Cadence directly to the laptop and bypassed the Bolt and Wahoo Companion app.
     
    John_V likes this.
  11. rola643

    rola643 Two skinny Js Staff Member Admin Staff Mod Team Tavern Member

    20,465
    8,885
    113
    There's no need in all that with Zwift, that's the way it's designed to work. Dongle and done :D
     
    Dos_Ruedas and John_V like this.
  12. Dos_Ruedas

    Dos_Ruedas Well-Known Member

    6,471
    4,576
    113